Squid Unsupported Version Detection

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains an unsupported version of a caching proxy
server.

Description :

According to its version, the installation of Squid on the remote host
is no longer supported. As a result, it is likely to contain security
vulnerabilities.

The project developers will provide fixes for versions as far back as
those labeled 'old', but not for versions before those.

See also :

http://www.squid-cache.org/Versions/
http://www.mail-archive.com/squid-users@squid-cache.org/msg82793.html

Solution :

Upgrade to a version of Squid that is currently supported.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Firewalls

Nessus Plugin ID: 57750 ()

Bugtraq ID:

CVE ID: