Apache Tomcat 6.x < 6.0.35 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is potentially affected by several
vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 6.x listening on the remote host is earlier than 6.0.35 and is,
therefore, potentially affected by multiple vulnerabilities.

- Specially crafted requests are incorrectly processed
by Tomcat and can cause the server to allow injection
of arbitrary AJP messages. This can lead to
authentication bypass and disclosure of sensitive
information. Note this vulnerability only occurs when
the following are true (CVE-2011-3190):

- the org.apache.jk.server.JkCoyoteHandler AJP
connector is not used.
- POST requests are accepted.
- the request body is not processed.

- An information disclosure vulnerability exists. Request
information is cached in two objects and these objects
are not recycled at the same time. Further requests can
obtain sensitive information if certain error conditions
occur. (CVE-2011-3375)

- Large numbers of crafted form parameters can cause
excessive CPU consumption due to hash collisions.
(CVE-2011-4858, CVE-2012-0022)

Note that Nessus did not actually test for these flaws but instead has
relied on the version in Tomcat's banner or error page.

See also :

https://issues.apache.org/bugzilla/show_bug.cgi?id=51698#c2
http://svn.apache.org/viewvc?view=revision&revision=1162959
http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.35
http://www.nruns.com/_downloads/advisory28122011.pdf

Solution :

Upgrade to Apache Tomcat version 6.0.35 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 57080 ()

Bugtraq ID: 49353
51200
51442
51447

CVE ID: CVE-2011-3190
CVE-2011-3375
CVE-2011-4858
CVE-2012-0022