OpenSSL 1.x < 1.0.0e Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple SSL-related
vulnerabilities.

Description :

According to its banner, the remote web server is running a version
of OpenSSL 1.x prior to 1.0.0e. It is, therefore, affected by the
following vulnerabilities :

- An error exists related to ECDSA signatures and binary
curves. The implementation of curves over binary fields
could allow a remote, unauthenticated attacker to
determine private key material via timing attacks.
(CVE-2011-1945)

- An error exists in the internal certificate verification
process that can allow improper acceptance of a
certificate revocation list (CRL) if the list's
'nextUpdate' field contains a date in the past. Note
that this internal CRL checking is not enabled by
default. (CVE-2011-3207)

- An error exists in the code for the ephemeral
(EC)DH cipher suites that can allow a remote attacker to
crash the process. (CVE-2011-3210)

See also :

http://openssl.org/news/secadv_20110906.txt
http://www.openssl.org/news/changelog.html
https://bugzilla.redhat.com/show_bug.cgi?id=736079
https://bugzilla.redhat.com/show_bug.cgi?id=736087
http://eprint.iacr.org/2011/232.pdf
http://www.nessus.org/u?4ffc1948

Solution :

Upgrade to OpenSSL 1.0.0e or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 56162 ()

Bugtraq ID: 47888
49469
49471

CVE ID: CVE-2011-1945
CVE-2011-3207
CVE-2011-3210