Apache Tomcat 7.x < 7.0.20 'jsvc' Information Disclosure

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by an information disclosure
vulnerability.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.x listening on the remote host is earlier than 7.0.20. As
such, it is potentially affected by an information disclosure
vulnerability.

A component that Apache Tomcat relies on called 'jsvc' contains an
error in that it does not drop capabilities after starting and can
allow access to sensitive files owned by the super user.

Note this vulnerability only affects Linux operating systems and only
when the following are true :

- jsvc is compiled with libpcap

- the '-user' parameter is used

Also note that Nessus did not actually test for the flaw but instead
has relied on the version in Tomcat's banner or error page.

See also :

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.20

Solution :

Upgrade to Apache Tomcat version 7.0.20 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 55859 ()

Bugtraq ID: 49143

CVE ID: CVE-2011-2729