Apache Tomcat 7.x < 7.0.17 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.

Synopsis :

The remote web server may be affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.x listening on the remote host is earlier than 7.0.17. As
such, it is potentially affected by the following vulnerabilities:

- An error handling issue exists related to the
MemoryUserDatabase that allows user passwords to be
disclosed through log files. (CVE-2011-2204)

- If loaded before other web applications, a malicious web
application can potentially access or modify the
web.xml, context.xml and TLD files of other web
applications on the system. (CVE-2011-2481)

- An input validation error exists that allows a local
attacker to either bypass security or carry out denial
of service attacks when the APR or NIO connectors are
enabled. (CVE-2011-2526)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page.

See also :


Solution :

Upgrade to Apache Tomcat version 7.0.19 or later. [Note that 7.0.17
and 7.0.18 are not affected but were never officially released.]

Risk factor :

Medium / CVSS Base Score : 4.4
CVSS Temporal Score : 3.8
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 55759 ()

Bugtraq ID: 48456

CVE ID: CVE-2011-2204