Postfix Cyrus SASL Authentication Context Data Reuse Memory Corruption

This script is Copyright (C) 2011 Tenable Network Security, Inc.


Synopsis :

The remote mail server is potentially affected by a memory corruption
vulnerability.

Description :

According to its banner, the version of the Postfix mail server
listening on this port is earlier than 2.5.13, 2.6.19, 2.7.4, or
2.8.3. Such versions may be vulnerable to a memory corruption attack
if they have Cyrus SASL enabled and are allowing authentication
methods other than ANONYMOUS, LOGIN, and PLAIN. Code execution as the
unprivileged postfix user may also be possible.

Note that Nessus did not test whether the remote server was using
Cyrus specifically, as opposed to another SASL library such as
Dovecot.

See also :

http://www.postfix.org/CVE-2011-1720.html
http://archives.neohapsis.com/archives/bugtraq/2011-05/0065.html

Solution :

Upgrade to Postfix 2.5.13 / 2.6.19 / 2.7.4 / 2.8.3 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: SMTP problems

Nessus Plugin ID: 54583 ()

Bugtraq ID: 47778

CVE ID: CVE-2011-1720