Atlassian Confluence 2.x >= 2.7 / 3.x < 3.4.9 Multiple Cross-Site Scripting Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.

Synopsis :

The remote web application is affected by multiple cross-site
scripting vulnerabilities.

Description :

According to its self-reported version number, the instance of
Atlassian Confluence on the remote host is version 2.x >= 2.7 or 3.x <
3.4.9 and as such, is affected by multiple cross-site scripting

Errors in the validation of input data to certain macros allow
unfiltered data to be returned to a user's browser. The affected
macros are: Include Page, Activity Stream, Action links of attachments
lists and Table of Contents.

Note that Nessus did not actually test for the flaw but instead has
relied on the version in Confluence's login page.

See also :

Solution :

Apply the vendor patches or update to Confluence version 3.4.9 or

Risk factor :

Low / CVSS Base Score : 3.5
CVSS Temporal Score : 2.9
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 53576 ()

Bugtraq ID: 47398