DB2 9.7 < Fix Pack 4 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple issues.

Description :

According to its version, the installation of DB2 9.7 on the remote
host is older than Fix Pack 4. Such versions are affected by one or
more of the following issues :

- An unspecified error in the Relational Data Services
component can be exploited to update statistics for
tables without the appropriate privileges. (IC72119)

- An error in the Relational Data Services component may
grant users privileges to execute non-DDL statements
after role membership has been revoked from its group.
(IC71375)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg1IC72119
http://www-01.ibm.com/support/docview.wss?uid=swg1IC71375
http://www-01.ibm.com/support/docview.wss?uid=swg21450666

Solution :

Apply DB2 Version 9.7 Fix Pack 4 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 53547 ()

Bugtraq ID: 47525

CVE ID: CVE-2011-1846
CVE-2011-1847