Apache Tomcat 7.x < 7.0.6 Manager Interface XSS

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by a cross-site scripting
vulnerability.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.x listening on the remote host is less than 7.0.6 and as
such, may be affected by a cross-site scripting vulnerability in its
HTML Manager interface. A remote attacker may be able to exploit this
to inject code into a user's browser via a crafted URL.

Note that Nessus did not actually test for this flaw but instead has
relied on the version in Tomcat's banner or error page.

See also :

http://www.nessus.org/u?1b4b157f
http://archives.neohapsis.com/archives/fulldisclosure/2011-02/0077.html

Solution :

Update Apache Tomcat to version 7.0.6 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 51976 ()

Bugtraq ID: 46174

CVE ID: CVE-2011-0013