Apache Tomcat 6.x < 6.0.30 / 7.x < 7.0.5 Multiple XSS

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by multiple cross-site scripting
vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat listening on the remote host is greater than 6.0.11 and less
than 6.0.30, or is 7.x and less than 7.0.5 and as such, may be
affected by multiple cross-site scripting vulnerabilities.

Several cross-site scripting vulnerabilities exist in the Tomcat
Manager application's 'sessionList.jsp' file. The parameters 'sort'
and 'orderby' are not properly sanitized before being returned to the
user and can be used to inject arbitrary script into the user's
browser.

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

Also note, in the case of Tomcat 7.x, successful exploitation requires
that the cross-site request forgery (CSRF) filter is disabled.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2010-11/0285.html
http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.30
http://www.nessus.org/u?37871cd8

Solution :

Update Apache Tomcat to version 6.0.30 / 7.0.5 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 51526 ()

Bugtraq ID: 45015

CVE ID: CVE-2010-4172