Apache Tomcat 3.x < 3.3.2 Multiple Vulnerabilities

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat service may be affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 3.x listening on the remote host is earlier than 3.3.2 and, as
such, may be affected by multiple vulnerabilities.

Unspecified cross-site scripting vulnerabilities exist in the 'ROOT'
and example applications shipped with this version of Tomcat.

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :

http://tomcat.apache.org/security-3.html#Fixed_in_Apache_Tomcat_3.3.2
http://archives.neohapsis.com/archives/bugtraq/2007-08/0019.html

Solution :

Upgrade to Apache Tomcat version 3.3.2 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 50526 ()

Bugtraq ID: 6720
25174

CVE ID: CVE-2003-0044
CVE-2007-3384