Apache 2.2.x < 2.2.17 Multiple Vulnerabilities

This script is Copyright (C) 2010-2015 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by several issues.

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is prior to 2.2.17. It is, therefore, affected by the
following vulnerabilities :

- Errors exist in the bundled expat library that may allow
an attacker to crash the server when a buffer is over-
read when parsing an XML document. (CVE-2009-3720 and
CVE-2009-3560)

- An error exists in the 'apr_brigade_split_line'
function in the bundled APR-util library. Carefully
timed bytes in requests result in gradual memory
increases leading to a denial of service.
(CVE-2010-1623)

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use or to check for the issues themselves.

See also :

http://www.nessus.org/u?1c39fa1c
http://httpd.apache.org/security/vulnerabilities_22.html

Solution :

Upgrade to Apache version 2.2.17 or later. Alternatively, ensure that
the affected modules are not in use.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 50070 (apache_2_2_17.nasl)

Bugtraq ID: 37203
36097
43673

CVE ID: CVE-2009-3560
CVE-2009-3720
CVE-2010-1623