Atmail WebMail < 6.2.0 (6.20) 'MailType' Parameter XSS

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server contains an application that is affected by a
cross-site scripting vulnerability.

Description :

According to its version, the Atmail WebMail install on the remote
host is earlier than 6.2.0 (6.20). Such versions are affected by a
cross-site scripting vulnerability because they fail to sanitize the
'MailType' parameter before using it to generate dynamic HTML content.

An unauthenticated, remote attacker may be able to leverage this issue
to inject arbitrary HTML or script code into a user's browser to be
executed within the security context of the affected site.

See also :

http://archives.neohapsis.com/archives/bugtraq/2010-09/0170.html

Solution :

Upgrade to Atmail WebMail 6.2.0 (6.20) or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 49696 (atmail_webmail_62.nasl)

Bugtraq ID: 43377

CVE ID: CVE-2010-4930