RHEL 3 / 4 / 5 : flash-plugin (RHSA-2010:0706)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.

Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated Adobe Flash Player package that fixes one security issue is
now available for Red Hat Enterprise Linux 3 and 4 Extras, and Red Hat
Enterprise Linux 5 Supplementary.

The Red Hat Security Response Team has rated this update as having
critical security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from
the CVE link in the References section.

The flash-plugin package contains a Mozilla Firefox compatible Adobe
Flash Player web browser plug-in.

This update fixes one vulnerability in Adobe Flash Player. This
vulnerability is detailed on the Adobe security page APSB10-22, listed
in the References section. If a victim loaded a page containing
specially crafted SWF content, it could cause flash-plugin to crash
or, potentially, execute arbitrary code. (CVE-2010-2884)

All users of Adobe Flash Player should install this updated package,
which upgrades Flash Player to version for users of Red Hat
Enterprise Linux 5 Supplementary, and version 9.0.283 for users of Red
Hat Enterprise Linux 3 and 4 Extras.

See also :


Solution :

Update the affected flash-plugin package.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.7
Public Exploit Available : true

Family: Red Hat Local Security Checks

Nessus Plugin ID: 49640 ()

Bugtraq ID: 43205

CVE ID: CVE-2010-2884