Samba 3.x < 3.5.5 / 3.4.9 / 3.3.14 sid_parse Buffer Overflow

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by a buffer overflow
vulnerability.

Description :

According to its banner, the version of Samba 3.x running on the
remote host is earlier than 3.5.5. The 'sid_parse()' and related
'dom_sid_parse()' functions in such versions fail to correctly check
their input lengths when reading a binary representation of a Windows
SID (Security ID).

An attacker who is able to get a connection to a file share, either
authenticated or via a guest connection, can leverage this issue to
launch a stack-based buffer overflow attack against the affected smbd
service and possibly execute arbitrary code.

Note that Nessus has not actually tried to exploit this issue or
determine if one of the patches has been applied.

See also :

https://bugzilla.samba.org/show_bug.cgi?id=7669
http://www.samba.org/samba/security/CVE-2010-3069.html
http://www.samba.org/samba/history/samba-3.5.5.html
http://www.samba.org/samba/history/samba-3.4.9.html
http://www.samba.org/samba/history/samba-3.3.14.html

Solution :

Either apply one of the patches referenced in the project's advisory
or upgrade to 3.5.5 / 3.4.9 / 3.3.14 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 49228 ()

Bugtraq ID: 43212

CVE ID: CVE-2010-3069