Apache Tomcat 6.0 < 6.0.28 Multiple Vulnerabilities

This script is Copyright (C) 2010-2015 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 6.0 listening on the remote host is earlier than Tomcat 6.0.28
and, as such, may be affected by multiple vulnerabilities.

- If a web app is configured to use BASIC or DIGEST
authentication and the 'realm-name' attribute is not
configured in that web app's 'web.xml' file, the remote
server's hostname or IP will be included in replies.

- An error exists in the handling of invalid values in
the 'Transfer-Encoding' header of a request. Attackers
can cause a denial of service or obtain sensitive
information. (CVE-2010-2227)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :


Solution :

Update Apache Tomcat to version 6.0.28 or later.

Risk factor :

Medium / CVSS Base Score : 6.4
CVSS Temporal Score : 5.6
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 48255 ()

Bugtraq ID: 41544

CVE ID: CVE-2010-2227