Apache Tomcat 5.x < 5.5.1 Information Disclosure

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat service may be affected by an information
disclosure vulnerability.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 5.x listening on the remote host is earlier than 5.5.1 and, as
such, may be affected by an information disclosure vulnerability.

Specifically, it may allow requests from a non-permitted IP address to
gain access to a context that is protected with a valve that extends
RequestFilterValve.

Note that Nessus did not actually test for the flaw but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :

https://issues.apache.org/bugzilla/show_bug.cgi?id=25835
http://tomcat.apache.org/security-5.html#Fixed_in_Apache_Tomcat_5.5.1
http://seclists.org/bugtraq/2008/Oct/81

Solution :

Update Apache Tomcat to version 5.5.1 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.2
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 47028 ()

Bugtraq ID: 31698

CVE ID: CVE-2008-3271