IBM DB2 9.1 < Fix Pack 8 Multiple Vulnerabilities

This script is Copyright (C) 2009-2015 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

According to its version, the IBM DB2 server running on the remote
host is prior to 9.1 Fix Pack 8. It is, therefore, affected by
multiple vulnerabilities :

- MODIFIED SQL DATA table function is not dropped even if
the maintainer does not have privileges to maintain the
objects. (IZ46773)

- It may be possible for an unauthorized user to insert,
update, or delete rows in a table. (IZ50078)

- An user without 'SETSESSIONUSER' privilege can perform

- The 'DASAUTO' command can be run by a non-privileged
user. (IZ40340)

See also :

Solution :

Apply IBM DB2 Version 9.1 Fix Pack 8 or later.

Risk factor :

Medium / CVSS Base Score : 6.4
CVSS Temporal Score : 4.7
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 42044 (db2_9fp8.nasl)

Bugtraq ID: 36540

CVE ID: CVE-2009-3471