Slackware 12.2 / current : kernel (SSA:2009-230-01)

This script is Copyright (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote Slackware host is missing a security update.

Description :

New Linux kernel packages are available for Slackware 12.2 and
-current to address a security issue. A kernel bug discovered by Tavis
Ormandy and Julien Tinnes of the Google Security Team could allow a
local user to fill memory page zero with arbitrary code and then use
the kernel sendpage operation to trigger a NULL pointer dereference,
executing the code in the context of the kernel. If successfully
exploited, this bug can be used to gain root access. At this time we
have prepared fixed kernels for the stable version of Slackware
(12.2), as well as for both 32-bit x86 and x86_64 -current versions.
Additionally, we have added a package to the /patches directory for
Slackware 12.1 and 12.2 that will set the minimum memory page that can
be mmap()ed from userspace without additional privileges to 4096. The
package will work with any kernel supporting the vm.mmap_min_addr
tunable, and should significantly reduce the potential harm from this
bug, as well as future similar bugs that might be found in the kernel.
More updated kernels may follow.

See also :

http://www.nessus.org/u?f87ae2f9
http://www.nessus.org/u?6bdb98d3

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Family: Slackware Local Security Checks

Nessus Plugin ID: 40622 ()

Bugtraq ID:

CVE ID: CVE-2009-2692