MySQL 5.1 < 5.1.32 XPath Expression DoS

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a denial of service
vulnerability.

Description :

The version of MySQL 5.1 installed on the remote host is earlier than
5.1.32 and is, therefore, affected by a denial of service vulnerability.
Specifically, an authenticated user can cause an assertion failure
leading to a server crash by calling 'ExtractValue()' or 'UpdateXML()'
using an XPath expression employing a scalar expression as a
'FilterExpr'.

See also :

http://bugs.mysql.com/bug.php?id=42495
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-32.html

Solution :

Upgrade to MySQL Community Server version 5.1.32 or later.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P)
CVSS Temporal Score : 3.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 35766 ()

Bugtraq ID: 33972

CVE ID: CVE-2009-0819