Samba 3.0.29 - 3.2.4 Potential Memory Disclosure

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Samba server may be affected by an information disclosure
vulnerability.

Description :

According to its banner, the version of the Samba server on the remote
host is between 3.0.29 and 3.2.4 inclusive. Such versions reportedly
can potentially leak arbitrary memory contents of the 'smbd' process
due to a missing bounds check on client-generated offsets of secondary
'trans', 'trans2', and 'nttrans' requests.

Note that Nessus has not actually tried to exploit this issue or
determine if the fix has been applied.

See also :

http://www.samba.org/samba/security/CVE-2008-4314.html
http://www.samba.org/samba/history/samba-3.0.33.html
http://www.samba.org/samba/history/samba-3.2.5.html

Solution :

Upgrade to Samba version 3.2.5 / 3.0.33 or later or apply the
appropriate patch referenced in the project's advisory.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 34993 ()

Bugtraq ID: 32494

CVE ID: CVE-2008-4314