IBM DB2 9.1 < Fix Pack 6 Multiple Vulnerabilities

This script is Copyright (C) 2008-2015 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

According to its version, the installation of IBM DB2 9.1 running on
the remote host is affected by one or more of the following issues :

- An unspecified error in 'SQLNLS_UNPADDEDCHARLEN()' may
lead to a segmentation fault in the DB2 server.

- DB2 does not mark inoperative or drop views and triggers
if the definer cannot maintain the objects. (IZ22306)

- Password-related connection string keyword values may
appear in trace output. (IZ23915)

See also :

Solution :

Apply IBM DB2 version 9.1 Fix Pack 6 or later.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 5.5
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 34475 (db2_9fp6.nasl)

Bugtraq ID: 31856

CVE ID: CVE-2008-4691