MySQL 5.1 < 5.1.26 Empty Bit-String Literal Token SQL Statement DoS

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is susceptible to a denial of service

Description :

The version of MySQL 5.1 installed on the remote host is earlier than
5.1.26. A bug in such versions can lead to a server crash in
'Item_bin_string::Item_bin_string' when handling an empty bit-string
literal (b''). Using a simple SELECT statement, an authenticated
remote user can leverage this issue to crash the database server and
deny service to legitimate users.

See also :

Solution :

Upgrade to MySQL version 5.1.26.

Risk factor :

Medium / CVSS Base Score : 4.0
CVSS Temporal Score : 3.3
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 34160 ()

Bugtraq ID: 31081

CVE ID: CVE-2008-3963