Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : libxml2 vulnerability (USN-640-1)

Ubuntu Security Notice (C) 2008-2013 Canonical, Inc. / NASL script (C) 2008-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Andreas Solberg discovered that libxml2 did not handle recursive
entities safely. If an application linked against libxml2 were made to
process a specially crafted XML document, a remote attacker could
exhaust the system's CPU resources, leading to a denial of service.

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 34094 ()

Bugtraq ID:

CVE ID: CVE-2008-3281