Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : emacs21, emacs22 vulnerabilities (USN-607-1)

Ubuntu Security Notice (C) 2008-2013 Canonical, Inc. / NASL script (C) 2008-2013 Tenable Network Security, Inc.

Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that Emacs did not account for precision when
formatting integers. If a user were tricked into opening a specially
crafted file, an attacker could cause a denial of service or possibly
other unspecified actions. This issue does not affect Ubuntu 8.04.

Steve Grubb discovered that the vcdiff script as included in Emacs
created temporary files in an insecure way when used with SCCS. Local
users could exploit a race condition to create or overwrite files with
the privileges of the user invoking the program. (CVE-2008-1694).

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 32187 ()

Bugtraq ID:

CVE ID: CVE-2007-6109