Apache-SSL ExpandCert() Function Certificate Handling Arbitrary Environment Variables Manipulation

This script is Copyright (C) 2008-2012 Tenable Network Security, Inc.


Synopsis :

The remote web server is prone to a memory disclosure / privilege
escalation attack.

Description :

According to its banner, the version of Apache-SSL installed on the
remote host is older than apache_1.3.41+ssl_1.59. Such versions fail
to properly sanitize certificate data before using it to populate
environment variables. By sending a client certificate with special
characters for the subject, a remote attacker can overwrite certain
environment variables used by the web server, resulting in memory
disclosure or potential privilege escalation in a web application.

See also :

https://www.cynops.de/advisories/CVE-2008-0555.txt
http://www.apache-ssl.org/advisory-cve-2008-0555.txt
http://archives.neohapsis.com/archives/bugtraq/2008-04/0022.html

Solution :

Upgrade to apache_1.3.41+ssl_1.59 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 31738 (apache_ssl_env_var_manipulation.nasl)

Bugtraq ID: 28576

CVE ID: CVE-2008-0555