GLSA-200705-21 : MPlayer: Two buffer overflows

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200705-21
(MPlayer: Two buffer overflows)

A buffer overflow has been reported in the DMO_VideoDecoder_Open()
function in file loader/dmo/DMO_VideoDecoder.c. Another buffer overflow
has been reported in the DS_VideoDecoder_Open() function in file
loader/dshow/DS_VideoDecoder.c.

Impact :

A remote attacker could entice a user to open a specially crafted video
file, potentially resulting in the execution of arbitrary code with the
privileges of the user running MPlayer.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200704-09.xml
http://www.gentoo.org/security/en/glsa/glsa-200705-21.xml

Solution :

All MPlayer users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-video/mplayer-1.0.20070321'

Risk factor :

High / CVSS Base Score : 7.6
(CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 25360 (gentoo_GLSA-200705-21.nasl)

Bugtraq ID:

CVE ID: CVE-2007-1246
CVE-2007-1387