GLSA-200701-07 : EMF/WMF file handling vulnerabilities

This script is Copyright (C) 2007-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200701-07
( EMF/WMF file handling vulnerabilities)

John Heasman of NGSSoftware has discovered integer overflows in the
EMR_POLYPOLYGON and EMR_POLYPOLYGON16 processing and an error within
the handling of META_ESCAPE records.

Impact :

An attacker could exploit these vulnerabilities to cause heap overflows
and potentially execute arbitrary code with the privileges of the user
running by enticing the user to open a document
containing a malicious WMF/EMF file.

Workaround :

There is no known workaround known at this time.

See also :

Solution :

All binary users should update to version 2.1.0 or
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-office/openoffice-bin-2.1.0'
All users should update to version 2.0.4 or later:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-office/openoffice-2.0.4'

Risk factor :

High / CVSS Base Score : 9.3

Family: Gentoo Local Security Checks

Nessus Plugin ID: 24205 (gentoo_GLSA-200701-07.nasl)

Bugtraq ID:

CVE ID: CVE-2006-5870