Slackware 10.0 / 10.1 / 10.2 / 9.1 / current : xine-lib (SSA:2005-283-01)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Slackware host is missing a security update.

Description :

New xine-lib packages are available for Slackware 9.1, 10.0, 10.1,
10.2, and -current to fix a security issue. A format string bug may
allow the execution of arbitrary code as the user running a xine-lib
linked application. The attacker must provide (by uploading or running
a server) specially crafted CDDB information and then get the user to
play the referenced audio CD. The official Xine advisory may be found
here: http://xinehq.de/index.php/security/XSA-2005-1

See also :

http://www.nessus.org/u?e143d4c9
http://www.nessus.org/u?f3bc4de7

Solution :

Update the affected xine-lib package.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Slackware Local Security Checks

Nessus Plugin ID: 19952 ()

Bugtraq ID:

CVE ID: CVE-2005-2967