Slackware 10.0 / current : alternate samba package for Slackware 10.0 (SSA:2004-208-01)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Slackware host is missing a security update.

Description :

It was pointed out that the new Samba packages for Slackware 10.0
(and -current) have a dependency on libattr.so that wasn't in the
previous packages. Since it's not the intent to introduce new
requirements in security patches (especially for stable versions), an
alternate version of the samba package is being made available that
does not require libattr.so. The original samba-3.0.5-i486-1.tgz
package for Slackware 10.0 will also remain in the patches directory
(at least for now, since it was just referenced in a security advisory
and the URL to it should remain working), and because the original
package works fine if the xfsprogs package (which contains libattr) is
installed. If you're running a full installation or have xfsprogs
installed, you do not need to update samba again.

See also :

http://www.nessus.org/u?f92d63cc

Solution :

Update the affected samba package.

Risk factor :

High

Family: Slackware Local Security Checks

Nessus Plugin ID: 18764 ()

Bugtraq ID:

CVE ID: