MiniShare Webserver HTTP GET Request Remote Overflow

This script is Copyright (C) 2005-2011 SensePost


Synopsis :

The remote web server is affected by a remote buffer overflow
vulnerability.

Description :

MiniShare 1.4.1 and prior versions are affected by a buffer overflow
flaw. A remote attacker could execute arbitrary commands by sending a
specially crafted file name in a the GET request.

Version 1.3.4 and below do not seem to be vulnerable.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2004-11/0208.html

Solution :

Upgrade to MiniShare 1.4.2 or higher.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 7.1
(CVSS2#E:F/RL:U/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 18424 ()

Bugtraq ID: 11620

CVE ID: CVE-2004-2271