MySQL < 5.0.90 / 5.1.43 / 5.5.0-m2 Multiple Buffer Overflows

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by several buffer overflow
vulnerabilities.

Description :

The version of MySQL installed on the remote host is older than
5.0.90, 5.1.43 or 5.5.0-m2. Such versions use yaSSL prior to 1.9.9,
that is vulnerable to multiple buffer overflows. These overflows allow
a remote attacker to crash the server.

See also :

http://www.nessus.org/u?409fbf00
http://www.nessus.org/u?d46c3ad9
http://bugs.mysql.com/bug.php?id=50227
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-43.html
http://dev.mysql.com/doc/refman/5.0/en/news-5-0-90.html
http://www.nessus.org/u?8426d86b
http://lists.mysql.com/commits/96697
https://isc.sans.edu//diary.html?storyid=7900

Solution :

Upgrade to MySQL version 5.0.90 / 5.1.43 / 5.5.0-m2 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17835 ()

Bugtraq ID: 37640
37943
37974

CVE ID: CVE-2009-4484