MySQL < 4.0.14 libmysqlclient Buffer Overflow

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

Arbitrary code could be executed by the database client library on
the remote host.

Description :

The version of MySQL installed on the remote host is older than 4.0.14.

The client library (libmysqlclient) is thus reportedly affected by a
buffer overflow. A local attacker could execute arbitrary code
through a long socket name.

Note that RedHat does not consider that this flaw is a security
issue.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2003-q2/1303.html

Solution :

Upgrade to MySQL version 4.0.14 or later.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:P)
CVSS Temporal Score : 3.4
(CVSS2#E:U/RL:U/RC:ND)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 17822 ()

Bugtraq ID: 7887

CVE ID: CVE-2003-1331