MySQL < 3.23.33 Multiple Buffer Overflows

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is vulnerable to several buffer
overflow attacks.

Description :

The version of MySQL installed on the remote host is affected by the
following vulnerabilities :

- A buffer overflow in libmysqlclient.so allows a remote
attacker to execute arbitrary code via a long host
parameter. (CVE-2001-1453)

- A buffer overflow allows a remote attacker to execute
arbitrary code via a long DROP DATABASE.
(CVE-2001-1454)

See also :

http://www.nessus.org/u?5396a2f5
http://dev.mysql.com/doc/refman/4.1/en/news-3-23-33.html
http://www.nessus.org/u?5396a2f5

Solution :

Upgrade to MySQL version 3.23.33 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17818 ()

Bugtraq ID: 2262

CVE ID: CVE-2001-1453
CVE-2001-1454