MySQL < 4.1.18 / 5.0.19 / 5.1.6 Denial of Service

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server is susceptible to a denial of service
attack.

Description :

The version of MySQL installed on the remote host is earlier than
4.1.18 / 5.0.19 / 5.1.6 and thus reportedly allows a remote,
authenticated user to crash the server via the str_to_date
function.

See also :

http://bugs.mysql.com/bug.php?id=15828

Solution :

Upgrade to MySQL version 4.1.18 / 5.0.19 / 5.1.6 or later.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P)
CVSS Temporal Score : 3.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17810 ()

Bugtraq ID: 18439

CVE ID: CVE-2006-3081