OpenSSL < 0.9.2b Session Reuse

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is vulnerable to an SSL session reuse attack.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.2b.

A remote attacker could reuse an SSL session under a different context
and bypass access control mechanisms based on client certificates.

See also :

http://archives.neohapsis.com/archives/bugtraq/1999_1/1074.html

Solution :

Upgrade to OpenSSL 0.9.8s or later as the 0.9.2 branch is no longer
supported.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Web Servers

Nessus Plugin ID: 17798 ()

Bugtraq ID:

CVE ID: CVE-1999-0428