OpenSSL < 0.9.7h / 0.9.8a Protocol Version Rollback

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote server is vulnerable to man-in-the-middle attacks.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.7h or 0.9.8a.

If the SSL_OP_MSIE_SSLV2_RSA_PADDING option is used, a remote attacker
could force a client to downgrade to a weaker protocol and implement a
man-in-the-middle attack.

See also :

Solution :

Upgrade to OpenSSL 0.9.7h / 0.9.8a or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17755 ()

Bugtraq ID: 15647

CVE ID: CVE-2005-2969