OpenSSL < 0.9.7-beta3 Buffer Overflow

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by an arbitrary code execution
vulnerability.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.7-beta3.

If Kerberos is enabled, a remote attacker could trigger a buffer
overflow with a long master key and execute arbitrary code.

Solution :

Upgrade to OpenSSL 0.9.7 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17752 ()

Bugtraq ID: 5361

CVE ID: CVE-2002-0657