OpenSSL 0.9.6 CA Basic Constraints Validation Vulnerability

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by a certificate validation
vulnerability.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.7.

Such versions do not verify the Basic Constraint for some
certificates. A remote attacker could perform a man-in-the-middle
attack.

Details on this weakness are missing. It is related to CVE-2002-0970.
OpenSSL 0.9.6 was reported as 'probably' vulnerable.

See also :

http://www.nessus.org/u?8e41b7c3

Solution :

Upgrade to OpenSSL 0.9.7 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Web Servers

Nessus Plugin ID: 17751 ()

Bugtraq ID:

CVE ID: CVE-2009-0653