OpenSSL 0.9.6 CA Basic Constraints Validation Vulnerability

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote server is affected by a certificate validation

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.7.

Such versions do not verify the Basic Constraint for some
certificates. A remote attacker could perform a man-in-the-middle

Details on this weakness are missing. It is related to CVE-2002-0970.
OpenSSL 0.9.6 was reported as 'probably' vulnerable.

See also :

Solution :

Upgrade to OpenSSL 0.9.7 or later.

Risk factor :

High / CVSS Base Score : 7.5

Family: Web Servers

Nessus Plugin ID: 17751 ()

Bugtraq ID:

CVE ID: CVE-2009-0653

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial