This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.
The remote web server uses a version of PHP that is affected by
According to its banner, the version of PHP 5.x installed on the
remote host is older than 5.1.5. Such versions may be affected by the
following vulnerabilities :
- The c-client library 2000, 2001, or 2004 for PHP does
not check the safe_mode or open_basedir functions.
- A buffer overflow exists in the sscanf function.
- The file_exists and imap_reopen functions do not check
for the safe_mode and open_basedir settings, which
allows local users to bypass the settings.
- Multiple heap-based buffer overflows exist in the
str_repeat and wordwrap functions in
- The cURL extension files permit the
CURLOPT_FOLLOWLOCATION option when open_basedir or
safe_mode is enabled, which allows attackers to perform
unauthorized actions. (CVE-2006-4483)
- A buffer overflow vulnerability exists in the
LWZReadByte_ function in ext/gd/libgd/gd_gif_in.c in the
GD extension. (CVE-2006-4484)
- The stripos function is affected by an out-of-bounds
See also :
Upgrade to PHP version 5.1.5 or later.
Risk factor :
Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 7.8
Public Exploit Available : true