GLSA-200501-40 : ngIRCd: Buffer overflow

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200501-40
(ngIRCd: Buffer overflow)

Florian Westphal discovered a buffer overflow caused by an integer
underflow in the Lists_MakeMask() function of lists.c.

Impact :

A remote attacker can exploit this buffer overflow to crash the ngIRCd
daemon and possibly execute arbitrary code with the rights of the
ngIRCd daemon process.

Workaround :

There is no known workaround at this time.

See also :

http://arthur.ath.cx/pipermail/ngircd-ml/2005-January/000228.html
http://www.gentoo.org/security/en/glsa/glsa-200501-40.xml

Solution :

All ngIRCd users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-irc/ngIRCd-0.8.2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16431 (gentoo_GLSA-200501-40.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0199