PunBB URL Quote Tag XSS

This script is Copyright (C) 2004-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that is prone to
cross-site scripting attacks.

Description :

According to its banner, the remote version of PunBB is vulnerable to
cross-site scripting attacks because the application does not validate
URL and quote tags. With a specially crafted URL, an attacker may be
able to inject arbitrary HTML and script code into a user's browser,
resulting in a loss of integrity.

See also :

http://www.punbb.org/changelogs/1.1.4_to_1.1.5.txt

Solution :

Upgrade to PunBB version 1.1.5 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: CGI abuses : XSS

Nessus Plugin ID: 15941 ()

Bugtraq ID:

CVE ID: