Apache mod_include get_tag() Function Local Overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a local buffer overflow
vulnerability.

Description :

The remote web server appears to be running a version of Apache that
is older than version 1.3.33.

This version is vulnerable to a local buffer overflow in the get_tag()
function of the module 'mod_include' when a specially crafted document
with malformed server-side includes is requested though an HTTP
session.

Successful exploitation can lead to execution of arbitrary code with
escalated privileges, but requires that server-side includes (SSI) is
enabled.

Solution :

Upgrade to Apache 1.3.33 or newer.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 15554 (apache_mod_include_priv_escalation.nasl)

Bugtraq ID: 11471

CVE ID: CVE-2004-0940