GLSA-200403-04 : Multiple security vulnerabilities in Apache 2

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200403-04
(Multiple security vulnerabilities in Apache 2)

Three vulnerabilities were found:
A memory leak in ssl_engine_io.c for mod_ssl in Apache 2.0.48 and below
allows remote attackers to cause a denial of service attack via plain
HTTP requests to the SSL port of an SSL-enabled server.
Apache fails to filter terminal escape sequences from error logs that
begin with the ASCII (0x1B) sequence and are followed by a series of
arguments. If a remote attacker could inject escape sequences into an
Apache error log, the attacker could take advantages of weaknesses in
various terminal emulators, launching attacks against remote users
including further denial of service attacks, file modification, and the
execution of arbitrary commands.
The Apache mod_disk_cache has been found to be vulnerable to a weakness
that allows attackers to gain access to authentication credentials
through the issue of caching HTTP hop-by-hop headers which would
contain plaintext user passwords. There is no available resolution for
this issue yet.

Impact :

No special privileges are required for these vulnerabilities. As a
result, all users are recommended to upgrade their Apache
installations.

Workaround :

There is no immediate workaround
a software upgrade is required. There
is no workaround for the mod_disk_cache issue
users are recommended to
disable the feature on their servers until a patched version is
released.

See also :

http://www.apache.org/dist/httpd/Announcement2.html
http://www.gentoo.org/security/en/glsa/glsa-200403-04.xml

Solution :

Users are urged to upgrade to Apache 2.0.49:
# emerge sync
# emerge -pv '>=www-servers/apache-2.0.49'
# emerge '>=www-servers/apache-2.0.49'
# ** IMPORTANT **
# If you are migrating from Apache 2.0.48-r1 or earlier versions,
# it is important that the following directories are removed.
# The following commands should cause no data loss since these
# are symbolic links.
# rm /etc/apache2/lib /etc/apache2/logs /etc/apache2/modules
# rm /etc/apache2/modules
# ** ** ** ** **
# ** ALSO NOTE **
# Users who use mod_disk_cache should edit their Apache
# configuration and disable mod_disk_cache.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14455 (gentoo_GLSA-200403-04.nasl)

Bugtraq ID: 9933

CVE ID: CVE-2004-0113