PHP 5.4.x < 5.4.29 'src/cdf.c' Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server uses a version of PHP that is affected by
multiple vulnerabilities.

Description :

According to its banner, the version of PHP 5.4.x installed on the
remote host is a version prior to 5.4.29. It is, therefore, affected
by the following vulnerabilities :

- A flaw exists with the 'cdf_unpack_summary_info()'
function within 'src/cdf.c' where multiple file_printf
calls occur when handling specially crafted CDF files.
This could allow a context dependent attacker to crash
the web application using PHP. (CVE-2014-0237)

- A flaw exists with the 'cdf_read_property_info()'
function within 'src/cdf.c' where an infinite loop
occurs when handling specially crafted CDF files. This
could allow a context dependent attacker to crash the
web application using PHP. (CVE-2014-0238)

- An out-of-bounds read exists in printf. (Bug #67249)

Note that Nessus has not attempted to exploit these issues, but has
instead relied only on the application's self-reported version number.

See also :

http://www.php.net/ChangeLog-5.php#5.4.29
https://bugs.php.net/bug.php?id=67327
https://bugs.php.net/bug.php?id=67328

Solution :

Upgrade to PHP version 5.4.29 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: CGI abuses

Nessus Plugin ID: 74291 ()

Bugtraq ID: 67759
67765
69271

CVE ID: CVE-2014-0237
CVE-2014-0238