ImageMagick < 6.8.8-5 Multiple PSD Handling Buffer Overflows

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by a
multiple buffer overflow vulnerabilities.

Description :

The remote Windows host is running a version of ImageMagick prior to
version 6.8.8-5. It is, therefore, affected by the following
vulnerabilities :

- A buffer overflow error exists related to PSD image
file handling and the 'DecodePSDPixels' function.
(CVE-2014-1958)

- A buffer overflow error exists related to PDF image
file handling and RLE decoding. (CVE-2014-2030)

Exploitation of these issues could result in a denial of service or
arbitrary code execution.

See also :

http://www.imagemagick.org/script/changelog.php

Solution :

Upgrade to ImageMagick 6.8.8-5 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 72722 ()

Bugtraq ID: 65478
65563

CVE ID: CVE-2014-1958
CVE-2014-2030