phpMyAdmin 3.x >= 3.3.1 / 4.x < 4.1.7 import.php XSS (PMASA-2014-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a PHP application that is affected by a
cross-site scripting vulnerability.

Description :

According to its self-identified version number, the phpMyAdmin install
hosted on the remote web server is 3.x later than 3.3.1 or 4.x prior to
4.1.7. It is, therefore, affected by a cross-site scripting
vulnerability because the 'import.php' script does not properly sanitize
the filenames of imported files.

See also :

http://www.phpmyadmin.net/home_page/security/PMASA-2014-1.php
http://www.nessus.org/u?33815603

Solution :

Either upgrade to phpMyAdmin 4.1.7 or later, or apply the patch from
the referenced link.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 3.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 72714 ()

Bugtraq ID: 65717

CVE ID: CVE-2014-1879