Apache Tomcat 7.0.x < 7.0.50 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.0.x listening on the remote host is a version prior to
7.0.50. It is, therefore, potentially affected by the following
vulnerabilities :

- The fix for CVE-2012-3544 was not complete and limits
are not properly applied to chunk extensions and
whitespaces in certain trailing headers. This error
could allow denial of service attacks. (CVE-2013-4322)

- The application allows XML External Entity (XXE)
processing that could disclose sensitive information.

Note that Nessus did not actually test for these flaws, but instead
has relied on the version in Tomcat's banner or error page so this may
be a false positive.

See also :


Solution :

Update to Apache Tomcat version 7.0.50 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 72691 ()

Bugtraq ID: 65767

CVE ID: CVE-2013-4322