Apache Tomcat 6.0.x < 6.0.39 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 6.0.x listening on the remote host is a version prior to
6.0.39. It is, therefore, potentially affected by the following
vulnerabilities :

- The version of Java used to build the application
could generate Javadoc containing a frame injection
error. (CVE-2013-1571)

- The fix for CVE-2005-2090 was not complete and the
application does not reject requests with multiple
Content-Length HTTP headers or with Content-Length
HTTP headers when using chunked encoding.

- The fix for CVE-2012-3544 was not complete and limits
are not properly applied to chunk extensions and
whitespaces in certain trailing headers. This error
could allow denial of service attacks. (CVE-2013-4322)

- The application allows XML External Entity (XXE)
processing that could disclose sensitive information.

- An error exists related to the 'disableURLRewriting'
configuration option and session IDs. (CVE-2014-0033)

Note that Nessus did not actually test for these flaws, but instead
has relied on the version in Tomcat's banner or error page so this may
be a false positive.

See also :


Solution :

Update to Apache Tomcat version 6.0.39 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 72690 ()

Bugtraq ID: 60634

CVE ID: CVE-2013-1571