Shockwave Player <= 12.0.7.148 Multiple Memory Corruption Vulnerabilities (APSB14-06)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser plugin that is affected
by multiple memory corruption vulnerabilities.

Description :

The remote Windows host contains a version of Adobe's Shockwave Player
that is prior to or equal to 12.0.7.148. It is, therefore, potentially
affected by two unspecified memory corruption vulnerabilities. A remote
attacker could exploit these issues by tricking a user into viewing a
malicious Shockwave file, resulting in arbitrary code execution.

See also :

http://helpx.adobe.com/security/products/shockwave/apsb14-06.html

Solution :

Upgrade to Adobe Shockwave Player 12.0.9.149 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 72435 ()

Bugtraq ID: 65490
65493

CVE ID: CVE-2014-0500
CVE-2014-0501